libreoffice

Solve libxml2 build problem

Submitted by Fekete Zoltán on Sat, 01/21/2017 - 19:24

When you experience problems building libxml2 or any other ports depending on it (e.g. libreoffice), see the error message of the compiler. If it contains undefined reference 'lzma_auto_compress', then simply remove lzma and lzmalib packages from the system and continue the build process.

Reason: The base system contains lzma library, and the uncompatible package version supresses if installed.