LibreOffice 5.2.4.2 does not build because librdf is too old

Submitted by Fekete Zoltán on Sat, 01/21/2017 - 20:08

LibreOffice 5.2.4.2 needs redland >=1.0.16, which provides librdf. Certainly you have installed 1.0.17 as a package. However the build system complains as: "librdf too old Need >=1.0.16" So, what?

My hackish solution is simply edit the file /usr/pkgsrc/misc/libreoffice/work/libreoffice-5.2.4.2/configure.ac

Try to find the string "with_system_redland".
Then change the "yes" to "no" for the found condition.

Then make install again.

Note: You have to repeate the edition after a certain "make clean" or "make distclean".